静态路由

静态路由配置简单拓扑图如下QQ截图20140427230216.png

首先配置好三台PC的IP和路由器接口

R1(config)#interface f0/0

R1(config-if)#ip address 192.168.3.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#interface s0/0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#clock rate 56000

R1(config-if)#no shutdown


R2(config)#interface s0/0/0

R2(config-if)#ip address 192.168.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config)#interface f0/0

R2(config-if)#ip address 192.168.4.1 255.255.255.0

R2(config-if)#no shutdown

R2(config)#interface s0/0/1

R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2(config-if)#clock rate 56000

R2(config-if)#no shutdown


R3(config)#interface s0/0/0

R3(config-if)#ip address 192.168.2.2 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#interface f0/0

R3(config-if)#ip address 192.168.5.1 255.255.255.0

R3(config-if)#no shutdown


配置好后,这时是ping不通其他的路由的

前.png

所以要配置静态路由命令如下

R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.2

//目标网络是192.168.2.0 对应的子网掩码是255.255.255.0 下一条的地址是192.168.1.2 这里也可以使用送出接口s0/0/0

R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.1.2

R1(config)#ip route 192.168.5.0 255.255.255.0 192.168.1.2


R2(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1

R2(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.2


R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

R3(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.1

R3(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.1

配置完场后ping一下

后.png

配置完成。

标签: none

添加新评论